Forgot your password?


We can reset the password for your Harmony account after we verify your identity.

Enter the email id you used to create your account.

Enter your email id

Please enter your email id.

Invalid email id

No account found with that email id. Please enter a different username or create a new account.

Please enter your email id.


To change your password, you must answer the security question.

Incorrect answer. Please ensure you answered the security question correctly.

Please answer the security question.

New password (minimum of 4 characters)

Please enter the new password

Password should have at least 4 characters

Confirm new password

Please confirm the password.

Passwords do not match.

Retyped Password should have at least 4 characters

The server encountered an internal error and was unable to complete your request. Please try again.

Congratulations!

Your password has been successfully reset. Please sign in using your username and new password.


We found your account information

The login information provided by you belongs to Harmony Remote Software.

Create your new MyHarmony.com account now. Once you create your account, you will be guided to copy your old remote configuration into your new account.


Harmony Remote Software
MyHarmony.com

Having trouble downloading or installing?

We recommend you to use the MyHarmony app. It is designed to eliminate browser compatibility and associated plug-in issues, and gives you better experience.

After your download is complete, open MyHarmony-App.exe from the downloaded folder and follow the installation instructions.

To access MyHarmony from your browser click here.

You may be asked to install/update plugins and set your browser to required security settings.

Alert

You do not meet the minimum system requirements for using MyHarmony app.

Supported OS versions are Windows XP SP3 and above, Mac 10.6 and above.

To access MyHarmony from a browser click here.

Download and Install MyHarmony

Supported OS: Windows XP SP3 and above, Mac 10.6 and above

Printer-friendly version

Accept and Download